[服务器] 网站出现症状:HTTP 错误 401.3 - 未经授权:访问由于 ACL 对所请求资源的设置被拒绝

[复制链接]
admin 发表于 2021-5-27 22:31:17 | 显示全部楼层 |阅读模式

登录后,购买下载资源更方便!

您需要 登录 才可以下载或查看,没有账号?立即注册

×
原因:IIS匿名用户一般属于Guests组,而我们一般把存放网站的硬盘的权限只分配给administrators组,这时候按照继承原则,网站文件夹也只有administrators组的成员才能访问,导致IIS匿名用户访问该文件的NTFS权限不足,从而导致页面无法访问。
% S  e/ w# m; [9 ?0 H/ L, V) U* j9 x9 O8 N
解决方案:1 K% i  M/ q+ {
给IIS匿名用户访问网站文件夹的权限,方法:进入该文件夹的安全选项,添加IIS匿名用户,并赋予相应权限,一般是读、写。 + n3 ~/ p6 q1 O" @, I0 B2 q
IIS特有的问题. o% F% d, c# G4 g1 c7 S
在IIS中选中这个文件夹点右键-属性-执行许可选“纯脚本”试试
5 H' E# a3 i2 ^9 H: e9 G' n" Uiis里你的虚拟目录,属性-〉目录安全性-〉编辑身份验证和访问控制, }7 B& R0 E, F7 e( \
网站属性里把“目录安全”-点“身分验证和访问控制”-“编辑”-去掉“启用匿名访问“钩去了就可以了
4 L- Z9 t% O: `( b7 n2 h# B* h: C" n" ]5 z
评论0

手机版|小黑屋|源码模版|全球支付|VISA信用卡|MASTER信用卡|科恒数字网-持续研发、集成、交付、运营方案资源库

GMT+8, 2026-9-22 21:48 , Processed in 0.072799 second(s), 10 queries , Gzip On, Redis On.

Powered by Discuz! X5.0

© 2001-2026 Discuz! Team.