[Wordpress] WordPress站点开启SSL(https)后提示”将您重定向的次数过多”解决策略

[复制链接]
admin 发表于 2023-2-21 12:53:43 | 显示全部楼层 |阅读模式

登录后,购买下载资源更方便!

您需要 登录 才可以下载或查看,没有账号?立即注册

×
网站服务器搬家,修改了wp-config文件中的数据库帐号密码,修改解析记录,等待域名解析成功,发现css样式丢失,后台提示重定向次数过多打不开。
8 P8 j0 }1 G5 q/ B* ^8 |9 ^% W6 y* w0 q. E
检查报错原因:& x5 W$ G$ S: q' N% ~" x
从浏览器检查,发现部分url并没有被https掉,而我们开启的强制https,所以就来回跳转5 p$ w0 I9 c: ?  [8 r! ^

1 v0 B2 j) q' Y4 @! v解决方法:
9 j( C. c: Y& a( s5 ^0 J修改根目录下的wp-config.php文件,在开头部分,加入以下代码:: ?  `& R* w% g/ X: I
3 P$ b5 o" i$ n4 m# m
  1. $_SERVER['HTTPS'] = 'on';define('FORCE_SSL_LOGIN', true);define('FORCE_SSL_ADMIN', true);
复制代码
强制刷新页面,已经正常了,以上就是给大家带来的WordPress站点开启SSL(https)后提示”将您重定向的次数过多”解决方法。  k5 ]0 C8 {0 }* U, n
评论0

手机版|小黑屋|源码模版|全球支付|VISA信用卡|MASTER信用卡|科恒数字网-持续研发、集成、交付、运营方案资源库

GMT+8, 2026-10-7 13:23 , Processed in 0.052397 second(s), 10 queries , Gzip On, Redis On.

Powered by Discuz! X5.0

© 2001-2026 Discuz! Team.